Помогите написать программу на паскале!!!!!!!!!!!!!!!!!!!!!!!!!
Дана прямоугольная матрица размером . Определить номер строки, сумма элементов которой максимальна, и поменять местами эту строку и последнюю строку матрицы. Если данная строка оказалась последней, выдать на экран сообщение, о том, что менять строки местами не нужно.
Ответы на вопрос
Ответил bena1976
0
На входе вводим с клавиатуры размерность массива: n строк и m столбцов.
Первые два вложенных цикла - это ввод двумерного массива с помощью датчика случайных чисел randomize.
Далее во вложенных циклах ищем максимальную сумму элементов по строкам и запоминаем номер строки в переменную k.
Строку с выводом s и k писать не нужно.
Далее один цикл обмена к-той строки и последней.
Последние вложенные циклы выводят изменённый массив.
Прежде чем выводить массив нужно поставить поверку:
If k=m then write(‘Менять строки местами не нужно’) else begin и последние два вложенных цикла.
Приложения:

Новые вопросы
Русский язык,
2 года назад
Русский язык,
2 года назад
Математика,
7 лет назад
Информатика,
7 лет назад
Математика,
9 лет назад