Информатика, вопрос задал Saint224 , 8 лет назад

Помогите написать программу на Паскале!
2-ое задание!

Приложения:

Ответы на вопрос

Ответил petyaGavrikov
0
const n=6;
var a:array[1..n]of integer=(4,2,23,3,100,8);
i,s,max:integer;
begin
s:=0;
for i:=1 to n do s:=s+a[i];
writeln('Среднее арифметическое = ',s/n:5:3);
max:=a[1];
for i:=2 to n do
 if a[i]>max then max:=a[i];
 writeln('max = ',max);
 end.

Результат:
Среднее арифметическое = 23.333
max = 100
Новые вопросы