Информатика, вопрос задал leeigor12345 , 1 год назад

Помогите написать программу на Паскале 15 вариант заранее спасибо

Приложения:

Ответы на вопрос

Ответил BobbyFresnel
0

===== PascalABC.NET =====

begin

 var n := ReadInteger('n =');

 var a := ArrRandomReal(n, -99, 99);

 a.Transform(p -> Round(p, 2));

 a.Println;

 var S := ReadReal('S =');

 var i := a.Select((v, i) -> (Abs(v - S), i)).MaxBy(p -> p[0])[1];

 Writeln('Значение ', a[i], ', номер в массиве ', i+1)

end.

Приложения:
Новые вопросы