Информатика, вопрос задал MrTreiser , 7 лет назад

ПОМОГИТЕ написать программу на ПАСКАЛЬ В целочисленной последовательности есть нулевые элементы создать новый массив из номеров этих элементов.Массив задан программой.
Dat[1]=0 Dat[6]=0
Dat[2]=13 Dat[7]=17
Dat[3]=79 Dat[8]=0
Dat[4]=23 Dat[9]=0
Dat[5]=0 Dat[10]=10

Ответы на вопрос

Ответил supersuperkirip54irs
0

var Dat:array [1..10] of integer;

i,k,j:integer;

a:array [1..10] of integer;

BEGIN

Dat[1]:=0;

Dat[2]:=13;

Dat[3]:=79;

Dat[4]:=23;

Dat[5]:=0;

Dat[6]:=0;

Dat[7]:=17;

Dat[8]:=0;

Dat[9]:=0;

Dat[10]:=10;

j:=1;

k:=0;

for i:=1 to 10 do

if (Dat[i]=0) then begin

a[j]:=i;

k:=k+1;

j:=j+1;

end;

for j:=1 to k do

write(a[j],' ');

end.

Новые вопросы