помогите написать программу на PascalABCNET
ВХОДНЫЕ ДАННЫЕ
Задано натуральное число N.
ВЫХОДНЫЕ ДАННЫЕ
Определите количество нулей в его записи.
Приложения:

Ответы на вопрос
Ответил Аноним
1
var
n:string;
i,k:integer;
begin
Writeln('Введите число: '); Read(n);
k:=0;
for i:=1 to length(n) do
if n[i]='0' then Inc(k);
Writeln('Количество нулей в числе равно ',k)
end.
Тестовое решение:
Введите число:
2053006204
Количество нулей в числе равно 4
n:string;
i,k:integer;
begin
Writeln('Введите число: '); Read(n);
k:=0;
for i:=1 to length(n) do
if n[i]='0' then Inc(k);
Writeln('Количество нулей в числе равно ',k)
end.
Тестовое решение:
Введите число:
2053006204
Количество нулей в числе равно 4
Новые вопросы
Русский язык,
1 год назад
Русский язык,
1 год назад
Химия,
2 года назад
Русский язык,
2 года назад
Биология,
7 лет назад