Информатика, вопрос задал dd9399399 , 8 лет назад

Помогите написать программу на pascal

Вычислить сумму квадратов вводимых чисел. числа вводятся, пока не будет нажат ноль.

Ответы на вопрос

Ответил Аноним
0
// PascalABC.NET 3.3, сборка 1611 от 06.01.2018
// Внимание! Если программа не работает, обновите версию!

begin
  Writeln('Сумма квадратов: ',ReadSeqIntegerWhile(t->t<>0).Select(t->t*t).Sum)
end.

Пример
16 -23 18 24 5 -12 7 11 9 5 2 0
Сумма квадратов: 2134
Новые вопросы