Помогите написать программу на C++ которая выводит пирамиду из чисел. С клавиатуры водится число и до этого числа строится пирамида. Вот как должно выглядеть(пример)
Приложения:

Ответы на вопрос
Ответил fedrfedr
2
Ответ:
#include <iostream>
using namespace std;
int main()
{
int n, i, j;
string s, c;
cout << "N = ";
cin >> n;
s = string(n, ' ');
for (i = 1; i <= n; i++) {
cout << "\n" << s;
s.erase(s.size() - 1);
for (j = 1; j <= i; j++) {
if (n <= 9)
c = " ";
else
c = i <= 9 ? " " : " ";
cout << c << i;
}
}
}
khasan001:
Спасибо огромное)
Новые вопросы
Литература,
1 год назад
Химия,
1 год назад
Геометрия,
1 год назад
История,
1 год назад
Алгебра,
7 лет назад