Помогите написать программу на C++ ( двумя способами)
Тема была циклы
Нужно написать то что во вложении с помощью двух циклов
1) c помощью цикла while
2) с помощью цикла do while
Приложения:

Ответы на вопрос
Ответил pacixor
0
//1) WHILE
#include <iostream>
using namespace std;
int main() {
double h = 4;
double S = 0;
double k = 5;
while (k <= 51) {
S = S + sqrt(k);
k = k + h;
}
cout << "Sum = " << S << endl;
system("pause");
return 0;
}
//2) DO WHILE
#include <iostream>
using namespace std;
int main() {
double h = 4;
double S = 0;
double k = 5;
do {
S = S + sqrt(k);
k = k + h;
} while (k <= 51);
cout << "Sum = " << S << endl;
system("pause");
return 0;
}
#include <iostream>
using namespace std;
int main() {
double h = 4;
double S = 0;
double k = 5;
while (k <= 51) {
S = S + sqrt(k);
k = k + h;
}
cout << "Sum = " << S << endl;
system("pause");
return 0;
}
//2) DO WHILE
#include <iostream>
using namespace std;
int main() {
double h = 4;
double S = 0;
double k = 5;
do {
S = S + sqrt(k);
k = k + h;
} while (k <= 51);
cout << "Sum = " << S << endl;
system("pause");
return 0;
}
Новые вопросы