Помогите написать программу на C++
Для данного числа Х найти минимальный делитель отличный от 1
Ответы на вопрос
Ответил averutin
0
#include <iostream>
using namespace std;
int main()
{
int x;
cout <<"Введите число: ";
cin >>x;
for(int i=2; i<=x; ++i)
if(x%i==0)
{
cout <<"Наименьший делитель равен ";
cout <<i <<endl;
break;
}
return 0;
}
using namespace std;
int main()
{
int x;
cout <<"Введите число: ";
cin >>x;
for(int i=2; i<=x; ++i)
if(x%i==0)
{
cout <<"Наименьший делитель равен ";
cout <<i <<endl;
break;
}
return 0;
}
Приложения:

Новые вопросы