Помогите написать программу на C++
Дана символьная строка, представляющая собой запись натурального числа в р-ичной системе счисления (2 ≤ р ≤ 9). Составить программу перевода этого числа в десятичную систему счисления. Используя рекурсию.
Заранее благодарю)
Ответы на вопрос
Ответил srzontmp
0
//перевод числа из системы исчисления
//с основанием от 2 до 9 в десятичную
#include <iostream>
#include <cstdlib>
#include <cstring>
using namespace std;
int pss(char sr[80], int i, int osn)
{
static int s;
char ch=sr[i-1];
if (i==strlen(sr)) s=1;
s=s*osn;
if (1<i) return (atoi(&ch)+pss(sr,i-1,osn)*osn);
else return (atoi(&ch));
}
int main(int argc, char** argv)
{
int osn=0;
char st[80];
cout<<" задайте основание (от 2 до 9) ";
cin>>osn; cout<<endl;
cout<<"число: "; cin>>st; cout<<endl;
cout<<"в десятичной системе: "
<<pss(st,strlen(st),osn);
return(0);
}
//с основанием от 2 до 9 в десятичную
#include <iostream>
#include <cstdlib>
#include <cstring>
using namespace std;
int pss(char sr[80], int i, int osn)
{
static int s;
char ch=sr[i-1];
if (i==strlen(sr)) s=1;
s=s*osn;
if (1<i) return (atoi(&ch)+pss(sr,i-1,osn)*osn);
else return (atoi(&ch));
}
int main(int argc, char** argv)
{
int osn=0;
char st[80];
cout<<" задайте основание (от 2 до 9) ";
cin>>osn; cout<<endl;
cout<<"число: "; cin>>st; cout<<endl;
cout<<"в десятичной системе: "
<<pss(st,strlen(st),osn);
return(0);
}
Ответил seq98
0
Всё очень хорошо,ноо #include <cstdlib>
#include <cstring> мы ещё не проходили(((
#include <cstring> мы ещё не проходили(((
Ответил srzontmp
0
Это директивы, подключаются библиотеки, чтобы можно было запустить программу и проверить ее работу
Новые вопросы
Информатика,
2 года назад
Английский язык,
2 года назад
Физика,
9 лет назад
Биология,
9 лет назад
Физика,
10 лет назад