Информатика, вопрос задал Shakir7571 , 8 лет назад

Помогите написать программу, которая определяет, кратное ли число четырём. На Pascal ABC и C++
Пример:
Ввод Вывод
32 Кратно 4
19 Не кратно 4

Ответы на вопрос

Ответил sevas58
0
#include <iostream>
using spacename std;
 void main(){
int a;

cin>> a;
if (a%4==0){
cout<<a<< "кратно 4";
}else{
cout<<a<<"не кратно 4";
}
  }





progeram p1;
uses crt; var a:integer; begin 
clrscr;read(a); 
write (a);if a mod 4 = 0 then 
 write("кратно 4"); 

else write ("не кратно 4");
readkey;
end.
Ответил sevas58
0
сори вечно забываю namespace
Ответил sevas58
0
прости ряльно просто заторопился и забыл
Ответил sevas58
0
ну что помогло?
Ответил Shakir7571
0
чеееел, если пишешь 19, то выводит что оно кратно
Ответил Shakir7571
0
в паскаль
Ответил NaaMan
0
// Программа будет выполняться до тех пор,
// пока не будет введено "0"
var
    a : integer;
begin
    a := 1;
    while a <> 0 do begin
        write('>> '); read(a);
        if a mod 4 <> 0 then
            write('не ');
        writeln('кратно 4')
    end
end.


Приложения:
Новые вопросы