помогите написать программу для решения этой задачи на паскале:"хватит ли N= 180 штук кафельной плитки шириной A= 0,2 м шириной B=0,3 м для покрытия пола в помещении площадью S=12 м²?"
Ответы на вопрос
Ответил petyaGavrikov
0
var a,b,s:real; n:integer;
begin
n:=180;
s:=12;
a:=0.2;
write('Ширина ',a:3:1,' - ');
if a*a*n>=s then writeln('Yes')
else writeln('No');
b:=0.3;
write('Ширина ',b:3:1,' - ');
if b*b*n>=s then writeln('Yes')
else writeln('No');
end.
Результат:
Ширина 0.2 - No
Ширина 0.3 - Yes
begin
n:=180;
s:=12;
a:=0.2;
write('Ширина ',a:3:1,' - ');
if a*a*n>=s then writeln('Yes')
else writeln('No');
b:=0.3;
write('Ширина ',b:3:1,' - ');
if b*b*n>=s then writeln('Yes')
else writeln('No');
end.
Результат:
Ширина 0.2 - No
Ширина 0.3 - Yes
Новые вопросы