Информатика, вопрос задал elena1lena , 7 лет назад

помогите !
написать программу для одномерного массива подсчёт кол-ва элементов массива, выше 30

Ответы на вопрос

Ответил elenaklon
0

const n=10;

var a:array [1..n] of integer;

i,k:integer;

begin

for i:= 1 to n do

begin

a[i]:=Random(90)+10;

write(a[i],'  ');

if a[i]>30 then k:=k+1

end;

writeln;

writeln ('Кол-во элементов массива, выше 30, равно: ',k)

end.

Ответил DeniSapezko
0
Только да, логичней было бы завести переменную, а не константу, значение которой мы скопируем со входного потока. А так да, решение правильное, можно и 4-ку поставить
Ответил DeniSapezko
0
Т.е. завести переменну, скопировать значения, и ввести n элементов, т.е. столько, скольким равняется данная переменная
Ответил Аноним
0

PascalABC.NET 3.4.2, сборка 1884 от 24.11.2018

Внимание! Если программа не работает, обновите версию!

begin

 var a := ArrRandom(ReadInteger('n='), -99, 99);

 a.Println;

 Writeln('Элементов со значением, превышающим 30: ',

     a.Where(t -> t > 30).Count)

end.

Пример

n= 17

29 8 -26 51 -32 -35 46 95 -90 58 66 64 19 -3 34 -8 45

Элементов со значением, превышающим 30: 8

Новые вопросы