Информатика, вопрос задал demidova95k , 8 лет назад

Помогите написать на Паскале
Дано N пицц Пиццу резать нельзя ! Если распределить пиццы поровну среди М друзей , то по скольку пицц получит каждый друг и сколько пицц окажутся не распределенными ? Программа получает на вход два натуральных числа N и M , при чем N > M. N не превосходит 10 9 Программа должна вывести два числа- сколько пицц достанется каждому другу и сколько пицц останется не распределенными через пробел

Ответы на вопрос

Ответил byaka0
0

До нельзя просто. div находит целое число от деления, mod — остаток. Путём деления и находим, кто сколько пицц скушает =)

program Pizza2friends;

var N,M:integer;

begin

writeln('Введите количество пицц');
read(N);
writeln('Введите количество друзей');
read(M);

if N > M then
writeln('У каждого друга будет ',N div M,' пицц. Останется ',N mod M,' ничьих пицц.')

else writeln('Пицц должно быть больше, чем друзей');

end.

Ответил TatyanaOskol
0
добавьте условие что N не превосходит 10^9
Ответил byaka0
0
program Pizza2friends;
var N,M:integer;
begin
writeln('Введите количество пицц');
read(N);
writeln('Введите количество друзей');
read(M);
if (N > M) and (N < exp(ln(10) * 9)) then
writeln('У каждого друга будет ',N div M,' пицц. Останется ',N mod M,' ничьих пицц.')
else writeln('Пицц должно быть больше, чем друзей и N не должно превышать 10^9.');
end.
Новые вопросы