Информатика, вопрос задал kristina2005841 , 2 года назад

ПОМОГИТЕ ! НАДО НАПИСАТЬ В ПИТОНЕ! Дано неотрицательное число N - количество элементов массива (N<=100)

Заполнить массив из N элементов первыми натуральными трехзначными числами, произведение цифр которых есть трехзначное число

Пример входных и выходных данных
№ теста Входные данные Выходные данные
1 5 269 278 279 287 288

Ответы на вопрос

Ответил restIess
3

N = int(input())

ch = 100

a = []

while len(a) != N and ch < 1000:

   s = (ch%10)*((ch//10)%10)*(ch//100)

   if s > 99 and s < 1000:

       a.append(ch)

   ch += 1

for i in range(len(a)):

   print(a[i],end=" ")


kristina2005841: СПАСИБО ОГРОМНОЕ!!!!
Новые вопросы