Информатика, вопрос задал ructamakmal1708zig , 1 год назад

Помогите на Python

Найди самого большого.
Пользователь вводит последовательность целых чисел (каждое число на новой строке). Если пользователь вводит 0, то последовательность заканчивается.
Напишите программу, которая будет считать индекс (порядковый номер) самого большого числа.

Подсказка: первое введенное число сначала является самым большим. Потом ситуация может поменяться. Мы принимаем новые числа ПОКА новое число не равно нулю.

Пример входа №1:

9
8
7
6
0
Пример результата №1:

1
Пример входа №2:

1
2
3
2
1
0
Пример результата №2:

3

Ответы на вопрос

Ответил mrpansar
6

num = int(input())

lst = []

while num != 0:

   lst.append(num)

   num = int(input())

print(lst.index(max(lst)) + 1)

Новые вопросы