Информатика, вопрос задал Julia9696 , 9 лет назад

Помогите мне пожалуйста с программой..(В паскале) Опишите процедуру поиска наибольшего и наименьшего элемента массива. С помощью этой процедуры составить программу, которая определяет совпадают ли наибольший и наименьший элементы двух массивов A[1..n], B[1..n].

Ответы на вопрос

Ответил kage1998
0
program gt;
var n,i,max,max2,min,min2:integer;
a,b:array[1..100]of integer;
procedure proverka(a:array[1..100]of integer;var max,min:integer);
begin
max:=a[1];min:=a[1];
for i:=1 to n do
begin
if(a[i]>max)then max:=a[i];
if(a[i]<min)then min:=a[i];
end;
end;
begin
readln(n);
for i:=1 to n do
read(a[i]);
for i:=1 to n do
read(b[i]);
proverka(a,max,min);
proverka(b,max2,min2);
if  (max = max2) and (min = min2) then writeln('YES')else
writeln('NO');
end.
Новые вопросы