Информатика, вопрос задал ekb2007 , 6 лет назад

Помогите допишите программу c++
Пользователь вводит данные о своих расходах в долларах за неделю (каждый день). Написать программу, которая вычисляет:

- среднюю (за неделю) потраченную сумму;
- общую сумму, потраченную пользователем за неделю;
- количество дней и их названия (например, «вторник»),
когда сумма расхода (в день) превысила 100 долларов

#include

using namespace std;

int main()
{
setlocale(LC_ALL, "Russian");
int a;
double day, sum = 0;
const char* Wday[] = { "Понедельник", "Вторник", "Среда", "Четверг",\
"Пятница", "Суббота", "Воскресенье" };

for (int i = 0; i < 7; i++)
{
cout << Wday[i] << " = ";
cin >> day;
sum += day;

if (day >= 100)
{
if (day > 100)
cout << Wday[i]; "\n";
}
}

cout << "Средняя (за неделю) потраченная сумма = " << sum / 7 << "$\n";
cout << "Общая сумма, потраченная пользователем за неделю = " << sum << "$\n";
cout << "Сумма расходов (в день) превысила 100$" << " " << "$\n";;

return 0;
}

Ответы на вопрос

Ответил icem7735
0

Ответ:

cout << "Средняя (за неделю) потраченная сумма = " << sum / 7 << "$\n";

cout << "Общая сумма, потраченная пользователем за неделю = " << sum << "$\n";

cout << "Сумма расходов (в день) превысила 100$" << " " << "$\n";;

Новые вопросы