Помогите,дам все сови баллы:
Написать программу котораяопределяет является ли число четнымили его запись окончательно целая 7
Ответы на вопрос
Ответил HIPM
0
var
num: integer;
begin
read(num);
if num mod 2 = 0 then write('Число четное') else write('Число нечетное');
end.
num: integer;
begin
read(num);
if num mod 2 = 0 then write('Число четное') else write('Число нечетное');
end.
Ответил HIPM
0
при чем там 7?
Ответил kry24
0
Да я сам хз так в эл написано :D
Ответил kry24
0
Вот и думаю как это делать)
Ответил kry24
0
И спасиб
Ответил HIPM
0
Я написал программу, которая определяет четное число или нет
Ответил Аноним
0
var
n:integer;
begin
Write('n = '); Read(n);
if (n mod 2=0) then Writeln('Число четное')
else begin
Write('Число нечетное и оно ');
if Abs(n mod 10)<>7 then Write('не ');
Writeln('оканчивается цифрой 7')
end
end.
Примеры
n = 3538
Число четное
n = 642301
Число нечетное и оно не оканчивается цифрой 7
n = 6306547
Число нечетное и оно оканчивается цифрой 7
n = -546347
Число нечетное и оно оканчивается цифрой 7
n:integer;
begin
Write('n = '); Read(n);
if (n mod 2=0) then Writeln('Число четное')
else begin
Write('Число нечетное и оно ');
if Abs(n mod 10)<>7 then Write('не ');
Writeln('оканчивается цифрой 7')
end
end.
Примеры
n = 3538
Число четное
n = 642301
Число нечетное и оно не оканчивается цифрой 7
n = 6306547
Число нечетное и оно оканчивается цифрой 7
n = -546347
Число нечетное и оно оканчивается цифрой 7
Новые вопросы