Информатика, вопрос задал chebudelphin , 7 лет назад

ПОМОГИТЕ!!!C++!!!сириус
НОК
Напишите программу, которая вычисляет наименьшее общее кратное двух чисел.

Входные данные

Входная строка содержит два натуральных числа, разделённые пробелом, — a и b. Гарантируется, что ответ не превосходит 2⋅109
Выходные данные

Программа должна вывести одно натуральное число: НОК заданных чисел.

Примеры
Ввод
Вывод
14 21
42

Ответы на вопрос

Ответил settom
1

Ответ:

#include <iostream>

using namespace std;

int main()

{

int a,b;

cin >> a >> b;

for (int i = 1; i < 2*109 +1; i++)

{

 if (i % a == 0 && i % b == 0) {

  cout << i;

  break;

 }

}

return 0;

}


chebudelphin: в не верном формате выводит
settom: в неверном, это как?
Ответил jenea9833
1

Ответ:

либо ответ выше,либо вот такая аналогия,которую я скину ниже

Объяснение:

#include <iostream>

#include <math.h>

using namespace std;

int main()

{

int n=0;

int a,b;

cout << "Введите a b" << endl;

cin >> a;

cin >> b;

bool bl ;

bl = true;

while ( bl==true){

n++;

if ((n%a== 0) &&(n%b == 0))

bl = false;

}

cout << "НОК = "<< n << endl;

system("pause");

return 0;

}


settom: Вот так изящнее
settom: do {
n++;
bl = (n % a == 0) && (n % b == 0);
} while (!bl);
Sofines15: #include
#include
#include
using namespace std;
int gcd(int a, int b) {
if (b == 0)
return a;
return gcd(b, a % b);
}
int main(){
int a, b;
cin >> a >> b;
cout << (a * b) / gcd(a, b);
}
Sofines15: А что не так с кодом?
Sofines15: Проверяю, все правильно. Отправила, система вывела, что неправильный ответ
Новые вопросы