Помогите c С#! Напишите программу, вычисляющую факториал от 2 до 13.
Ответы на вопрос
Ответил petyaGavrikov
0
using System;
class Program
{
public static void Main()
{
long f = 1;
for (int i = 2; i <= 13; i++)
{
f = f*i;
Console.WriteLine("{0}! = {1}", i, f);
}
Console.ReadKey();
}
}
Результат:
2! = 2
3! = 6
4! = 24
5! = 120
6! = 720
7! = 5040
8! = 40320
9! = 362880
10! = 3628800
11! = 39916800
12! = 479001600
13! = 6227020800
class Program
{
public static void Main()
{
long f = 1;
for (int i = 2; i <= 13; i++)
{
f = f*i;
Console.WriteLine("{0}! = {1}", i, f);
}
Console.ReadKey();
}
}
Результат:
2! = 2
3! = 6
4! = 24
5! = 120
6! = 720
7! = 5040
8! = 40320
9! = 362880
10! = 3628800
11! = 39916800
12! = 479001600
13! = 6227020800
Ответил innesa1702
0
Спасибо!
Ответил petyaGavrikov
0
Пожалуйста.
Ответил innesa1702
0
Пишет: Ошибка 1 Требуется определение типа или пространства имен, либо признак конца файла C:Users555AppDataLocalTemporary ProjectsConsoleApplication1Program.cs 2 1 ConsoleApplication1
Ошибка 2 Предложение using должно предшествовать любым другим элементам пространства имен кроме объявлений внешних псевдонимов C:Users555AppDataLocalTemporary ProjectsConsoleApplication1Program.cs 3 1 ConsoleApplication1
Ошибка 2 Предложение using должно предшествовать любым другим элементам пространства имен кроме объявлений внешних псевдонимов C:Users555AppDataLocalTemporary ProjectsConsoleApplication1Program.cs 3 1 ConsoleApplication1
Ответил innesa1702
0
Спасибо!Все правильно!
Ответил petyaGavrikov
0
:)
Новые вопросы