Информатика, вопрос задал innesa1702 , 9 лет назад

Помогите c С#! На основании алгоритмов напишите программу поиска максимального элемента в массиве из 10 элементов.

Ответы на вопрос

Ответил petyaGavrikov
0
using System;

class Program
{
        static void Main(string[] args)
        {
            int n=10;
            int[] a = new int[n];
            int max;
            Random r = new Random();
            Console.WriteLine("Массив a:");
            for (int i = 0; i < n; i++)
            {
                a[i] = r.Next(41)-20;
                Console.Write("{0,5}", a[i]);
            }
            Console.WriteLine();
            max = a[0];
            for (int i = 1; i < n; i++)
                if (a[i]>max) max = a[i];
            Console.Write("max = {0}", max);
            Console.ReadKey();
        }
}

Пример:
Массив a:
 3 7 17 -11 9 20 7 3 -15 10
max = 20
Ответил innesa1702
0
Спасибо!
Ответил archery
0
а зачем переменная N?
Ответил archery
0
такое впечатление что на паскале писали а не на шарпе
Ответил archery
0
using System;

class Program
{
static void Main()
{
var a = new int[10];
var r = new Random();

Console.WriteLine("Массив a:");
for (int i = 0; i < a.Length; i++)
{
a[i] = r.Next(-20, 20);
Console.Write("{0,5}", a[i]);
}
Console.WriteLine();

var max = a[0];
foreach (var element in a) {
max = (element > max) ? element : max;
}

Console.WriteLine("max = {0}", max);
Console.ReadKey();
}
}
Ответил archery
0
и это еще без дженериков и линкью
Новые вопросы