Помогите буду благодарен.Напишите программу, которая вычислит среднее арифметическое и среднее геометрическое трех произвольных чисел.. программа паскаль.
Ответы на вопрос
Ответил daniilkapatsyna
0
Ответ:program AverageCalculator;
var
num1, num2, num3: real;
arithmeticMean, geometricMean: real;
begin
writeln('Введите три числа:');
readln(num1, num2, num3);
arithmeticMean := (num1 + num2 + num3) / 3;
geometricMean := power((num1 * num2 * num3), 1/3);
writeln('Среднее арифметическое:', arithmeticMean:0:2);
writeln('Среднее геометрическое:', geometricMean:0:2);
readln;
end.
Объяснение:Программа запрашивает у пользователя ввести три числа, затем вычисляет среднее арифметическое и среднее геометрическое этих чисел. Результаты выводятся на экран с точностью до двух знаков после запятой.
Новые вопросы
Оʻzbek tili,
1 год назад
Химия,
1 год назад
История,
1 год назад
Литература,
1 год назад
Английский язык,
6 лет назад
Математика,
6 лет назад