Информатика, вопрос задал K2555888 , 10 лет назад

Помогиииите! Нужно написать программу которая определяет является ли сумма цифр двухзначного числа четной

Ответы на вопрос

Ответил logoyt
0

если число не очень длинное, то можно считать в стринг. но если число длинное, то это не прокатит

 

var

q:string;

i,a,n:integer;

 

begin

readln(q):

n:=length(q);

for i:=1 to n do

a:=strtoint(q[i]);

if a mod 2 = 0 then writeln("YES) else writeln("NO");

 

end.

Новые вопросы