Поменяйте местами k1-ый и k2-ой элементы данного массива размерностью N (N < 50). И выведите все элементы по порядку.
Формат входных данных
N - количество элементов в массиве Arr
Arrn - элементы массива (-50 < Arrn < 50)
k1, k2 - элементы массива, которые необходимо поменять местами.
Формат выходных данных
Строка, содержащая элементы массива, полученного после перестановки, записанные по порядку через пробел.
входные данные
6
-16 -7 -10 6 -11 10
5 6
выходные данные
-16 -7 -10 6 10 -11
Решить в c++
SergeySerg2002:
ща сделаю, наверное)
Ответы на вопрос
Ответил SergeySerg2002
1
Ответ:
#include <iostream>
int main() {
const int SIZE = 6;
int temp, k1 = 4, k2 = 5; // индексация массива начинается с 0 !!!
int arr[SIZE] = {-16, -7, -10, 6, -11, 10};
temp = arr[k2];
arr[k2] = arr[k1];
arr[k1] = temp;
for (int i = 0; i < SIZE; i++)
std::cout << arr[i] << "\t";
return 0;
}
Новые вопросы