Информатика, вопрос задал annap6570 , 2 года назад

Пользователь вводит любую строку. Программа выводит кол-во символов, кол-во пробелов, кол-во гласный букв.Напишите программу в n чисел (от 1 до 100). Все числа записываеться в list. Программа выводит среднее арифметичиское значение всего массива


trueberry17: язык какой
trueberry17: и среднее арифметическое от 0 до 100 - это уже второй код, верно?

Ответы на вопрос

Ответил 558mvgh
0

Ответ:

1) s=input()

glas=['а','я','у', 'ю', 'о', 'е', 'ё', 'э', 'и', 'ы']

symbols=k=p=0

for i in s:

   symbols+=+1

   if i==' ':

       p+=+1

   elif i in glas:

       k+=+1

print(f'Количество символов={symbols}, количество гласных={k}, количество пробелов={p}.')

2) from random import randint

a=[randint(1,100) for i in range(10)]

sum=0

print(a)

for i in a:

   sum+=+i

print(sum/10)

Объяснение:

Новые вопросы