Информатика, вопрос задал Nigger8888 , 1 год назад

Пользователь вводит число. Написать программу, которая оценивает это
число:
• Если число четное, и положительное (>0), то вывести «Категория А»
• Если же число четное и отрицательное (<0) – вывести «Категория B»
• Если число нечетное и положительное – «Категория С»
• И если число нечетное и отрицательное – «Категория D»

Ответы на вопрос

Ответил a87086828
1

Ответ:

Объяснение:

def evaluate_number(num):

   if num > 0 and num % 2 == 0:

       return "Категория А"

   elif num < 0 and num % 2 == 0:

       return "Категория B"

   elif num > 0 and num % 2 != 0:

       return "Категория С"

   elif num < 0 and num % 2 != 0:

       return "Категория D"

# Проверка функции

num = int(input("Введите число: "))

print(evaluate_number(num))

Новые вопросы