Получить массив N=10 из следующих чисел [-15; 15].Посчитать сумму элементов, которые заканчиваются на 5 и на 8.
Помогите пожалуйста составить программу.
антагонист:
какой язык?
Ответы на вопрос
Ответил vladmor
1
//PascalABC.NET (версия 3.1, сборка 1210 от 29.03.2016)
const n = 10;
var a: array[1..n] of integer;
i,s:integer;
begin
for i:=1 to n do begin
a[i]:=random(31)-15;
write(a[i]:4);
if (abs(a[i]) mod 10 = 5) or (abs(a[i]) mod 10 = 8) then s:=s+a[i];
end;
writeln;
writeln('Сумма оканчивающихся на 5 или 8 : ', s);
end.
Тестовое решение:
8 12 4 2 -10 10 -10 2 8 -13
Сумма оканчивающихся на 5 или 8 : 16
const n = 10;
var a: array[1..n] of integer;
i,s:integer;
begin
for i:=1 to n do begin
a[i]:=random(31)-15;
write(a[i]:4);
if (abs(a[i]) mod 10 = 5) or (abs(a[i]) mod 10 = 8) then s:=s+a[i];
end;
writeln;
writeln('Сумма оканчивающихся на 5 или 8 : ', s);
end.
Тестовое решение:
8 12 4 2 -10 10 -10 2 8 -13
Сумма оканчивающихся на 5 или 8 : 16
Ответил антагонист
1
var b,sum:integer;
a :array [0..31] of integer;
begin
sum:=0;
randomize;
for b:=0 to 9 do begin
a[b]:= random(31)-15;
writeln(a[b]);
if (abs( a[b] mod 10) = 5) or (abs (a[b] mod 10) = abs(8)) then sum:=sum+a[b];
end;
writeln('сумма элементов оканчивавшихся на 5 или 8 = ',sum)
end.
a :array [0..31] of integer;
begin
sum:=0;
randomize;
for b:=0 to 9 do begin
a[b]:= random(31)-15;
writeln(a[b]);
if (abs( a[b] mod 10) = 5) or (abs (a[b] mod 10) = abs(8)) then sum:=sum+a[b];
end;
writeln('сумма элементов оканчивавшихся на 5 или 8 = ',sum)
end.
Новые вопросы