Подсчитайте за один проход массива, сколько его элементов равны максимальному элементу.
Входные данные
На вход программе сначала подается значение n100 — количество элементов в массиве. В следующей строке входных данных расположены сами элементы массива — целые числа, по модулю не превосходящие 30 000.
Выходные данные
Выдайте количество искомых элементов массива.
Примеры
входные данные
8
4 3 5 2 5 1 3 5
выходные данные
3
Ответы на вопрос
Ответил Аноним
0
Var
A:array[1..100] of integer;
i,M,N,k:integer;
Begin
ReadLn(N);
M:=-30001;
k:=0;
For i:= 1 to N do
Begin
Read(A[i]);
if A[i]>M then
Begin
k:=0;
M:=A[i]
End;
if A[i]=M then k:=k+1
End;
WriteLn(k)
End.
A:array[1..100] of integer;
i,M,N,k:integer;
Begin
ReadLn(N);
M:=-30001;
k:=0;
For i:= 1 to N do
Begin
Read(A[i]);
if A[i]>M then
Begin
k:=0;
M:=A[i]
End;
if A[i]=M then k:=k+1
End;
WriteLn(k)
End.
Ответил Аноним
0
Спасибо большое!
Новые вопросы