Информатика, вопрос задал yokii , 10 лет назад

По данным x, y составить программу в Паскале для вычисления функции z:
1) z=(min(x, y)+0,5))/(1+max^2(x, y)).

2)z=система max(x, y), x<0
                    min(x, y), x>=0.

Ответы на вопрос

Ответил Mepkypuu
0
1)var x,y,z,min,max:real;
begin
readln(x,y);
if x>y then 
begin
max:=x;
min:=y;
end
else if x<y then
begin
max:=y;
min:=x;
end;
z:=(min+0.5)/(1+sqr(max));
writeln(z);
end.
2)
var x,y,z,min,max:real;
begin
readln(x,y);
if x>y then
begin
max:=x;
min:=y;
end
else if x<y then
begin
max:=y;
min:=x;
end;
if x<0 then
z:=max
else if x>=0 then
z:=min;
writeln(z);
end.
Новые вопросы