Информатика, вопрос задал 2SAnastasiAS2 , 2 года назад

плиз помощь
Напишите программу, которая считывает с клавиатуры два целых числа и строку.Если эта строка является обозначением одной из четырѐх математических операций (+, -, *,/), то выведите результат применения этой операции к введѐнным ранее числам, в противном случае выведите «Неверная операция». Если пользователь захочет поделить на ноль, выведите текст«На ноль делить нельзя!».На вход программе подаются два целых числа, каждое на отдельной строке, и строка.Программа должна вывести результат применения операции к введенным числам или соответствующий текст, если операция невернаялибо если происходит деление на ноль.


pinguinbird: На каком языке программирования писать? )

Ответы на вопрос

Ответил pinguinbird
6

Python:

while True:

 try:

   a = int(input('Введите a: '))

   break

 except ValueError:

   print('Вводите целое число!')

while True:

 try:

   b = int(input('Введите b: '))

   break

 except ValueError:

   print('Вводите целое число!')

c = input('Введите действие (+,-,*,/): ')

if c == '+': print(a+b)

elif c == '-': print(a-b)

elif c == '*': print(a*b)

elif c == '/':

 if b != 0: print(a/b)

 else: print('На ноль делить нельзя')

else: print('Неверная операция')


2SAnastasiAS2: а можно здесь тоже написать попороще, без слов (break, except ValueError....) .отмечу как лучший ответ)))
pinguinbird: да, конечно, сделаю попозже...
pinguinbird: a = int(input('Введите a: '))
b = int(input('Введите b: '))
c = input('Введите действие (+,-,*,/): ')
if c == '+': print(a+b)
elif c == '-': print(a-b)
elif c == '*': print(a*b)
elif c == '/' and b != 0: print(a/b)
elif c == '/' and b == 0: print('На ноль делить нельзя')
else: print('Неверная операция')
Новые вопросы