Плиз, помогите с задачей на Паскаль!
Составить программу для решения задачи: дано натуральное число n. Вычислить n!!, определяемое как произведение честных чисел от 2 до n, если n честно, либо как произведение нечетных чисел от 1 до n, если n нечетно.
Ответы на вопрос
Ответил raf1O5
1
program raf105;
var
n,pro: integer;
begin
write('n = ');
readln(n);
pro:= n;
while n-2 > 0 do
begin
pro:= pro * (n-2);
n:= n - 2;
end;
writeln('Вывод: ',pro);
end.
PascalABC
Новые вопросы
Українська література,
1 год назад
Математика,
1 год назад
Математика,
2 года назад
Физкультура и спорт,
7 лет назад