Информатика, вопрос задал peachpeach705 , 2 года назад

ПИТОН. ПОЖАЛУЙСТА ОЧЕНЬ СРОЧНО НУЖНО
Напишите программу, которая в последовательности натуральных чисел определяет сумму всех чисел, кратных 6 и оканчивающихся
на 2.программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0(0-признак окончание ввода, не входит в последовательность). Количество чисел не превышает 100. Введённые числа не превышают 30000.
Программа должна вывести одно число:сумму все чисел, кратных 6 и оканчивающихся на 2.
Пример работы программы:
Входные данные
42
6
32
20
12
0
Выходные данные
54

Ответы на вопрос

Ответил tyngpuk
1

Ответ:

s=0

a=int(input())

while a!=0:

   if a%6==0 and a%10==2:

       s+=a

   a=int(input())

print(s)

Новые вопросы