Информатика, вопрос задал GFedorov , 7 лет назад

Питон
Пользователь вводит последовательность из любых чисел. С помощью цикла while и вложенных условий необходимо написать программу, которая просуммирует отдельно все положительные и все отрицательные числа.

Если пользователь введёт «0», программа должна прекратить работу и выдать два результата: сумму положительных чисел и сумму отрицательных чисел, отдельно друг от друга в столбик.

Ответы на вопрос

Ответил boberon
1

positive_sum = 0

negative_sum = 0

while True:

   number = float(input('> '))

   if number > 0:

       positive_sum += number

   elif number < 0:

       negative_sum += number

   else:

       break

 

print('Sum of positive numbers:', positive_sum)

print('Sum of negative numbers:', negative_sum)

Новые вопросы