Информатика, вопрос задал alexsmir08 , 7 лет назад

ПИТОН
Нужно с помощью цикла for
Факториал
По данному целому неотрицательному n вычислите значение n!.

Входные данные

Вводится число n (0≤n≤15).

Выходные данные

Выведите ответ на задачу.

Примеры
Ввод 3
Вывод 6


MrSolution: Вам ответ уже 100 раз написали и рекурсией и вашим циклом for. Что не так??? Причем циклом for в первую очередь?

Ответы на вопрос

Ответил tutu007
4

Ответ:

n=int(input())

start=1

for i in range(1,n+1):

   start*=i

print(start)

Новые вопросы