Информатика, вопрос задал styles23 , 6 лет назад

Питон

Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221).

Входные данные
Входная строка содержит одно натуральное число.

Выходные данные
Программа должна вывести слово 'YES', если в числе есть две одинаковые цифры, стоящие рядом, и слово 'NO', если такой пары цифр нет.

Примеры
входные данные
5221
выходные данные
YES
входные данные
1232
выходные данные
NO

Ответы на вопрос

Ответил 2shark2
1

Надеюсь, правильно.

a = input()

c = 0

for b in range(len(a)):

   if b < len(a) - 1:

       if a[b] == a[b + 1]:

           c = 1

if c == 1:

   print('YES')

else:

   print('NO')


styles23: Большое спасииибо
2shark2: Пожалуйста:)
Новые вопросы