Информатика, вопрос задал alexsmir08 , 7 лет назад

ПИТОН
напишите программу
Факториал
По данному целому неотрицательному n вычислите значение n!.

Входные данные

Вводится число n (0≤n≤15).

Выходные данные

Выведите ответ на задачу.

Примеры
Ввод
3
Вывод
6

Ответы на вопрос

Ответил MrSolution
4

Ответ:

(см. объяснение)

Объяснение:

n=int(input())

a=1

for i in range(2,n+1):

   a*= i

print(a)

Задание выполнено!

Ответил restIess
1

def _factorial(n):

   if n < 0:

       return 0

   if n == 0:

       return 1

   else:

       return n * _factorial(n-1)

print(_factorial(int(input("Введите число: "))))

Новые вопросы