Информатика, вопрос задал liza2311xx , 6 лет назад

ПИТОН Написать программу, которая вводит последовательность целых чисел, заканчивающуюся нулем, и определяет, сколько из этих чисел удовлетворяют условию: сумма значений цифр десятичной записи числа равна 10. ​

Ответы на вопрос

Ответил Kvint123
1

Ответ:

n=''

b=[]

v=0

g=0

k=0

while n!=0:

   n=int(input())

   if n!=0:

       b.append(n)

for i in range(len(b)):

   g=abs(b[i])

   v=sum(map(int,str(g)))

   if v==10:

       k=k+1

print(k)

   

Объяснение:


liza2311xx: а без масивов нельзя?
Новые вопросы