Информатика, вопрос задал fedorigors09 , 6 лет назад

Питон
Дано число x. Необходимо найти все его натуральные делители (включая 1 и само число).

Формат входных данных
Вводится одно целое число x (1≤x≤215−1).

Формат выходных данных
Требуется вывести все искомые делители в порядке возрастания.


fedorigors09: Питон

Ответы на вопрос

Ответил vimmortal2
1

Программа:

Python:

x = int(input('x = '))

for i in range(1, x + 1):

   if not x % i:

       print(i)

Объяснение:
В начале вводится само число х. После - с помощью цикла проходимся по всем числам от 1 до числа х включительно, и если нет остатка от деления (при делении х на i), то число i выводится.

Новые вопросы