Информатика, вопрос задал mrforet00 , 7 лет назад

(ПИТОН)Дан целочисленный массив из 10 элементов. Элементы массива могут принимать произвольные целые значения. Напишите программу, которая находит и выводит номера двух элементов массива, сумма которых максимальна. Исходные данные объявлены так, как показано ниже.

a = []

n = 10

for i in range(0, n):

a.append(int(input()))

...

Ответы на вопрос

Ответил MupoTBopec
0

Пояснение:

Сумма будет максимальной в том случае, если будут суммированы два самых больших числа в массива. То есть необходимо их найти и вывести их индексы. Программа снизу как раз это и вычисляет через два прохода цикла for

a = [] #объявление списка    

n = 10 #кол-во элементов в списке

for i in range(0,n): #заполнение списка

   a.append(int(input('Введите ['+ str(i) + "] элемент: ")))

max_number = 0 #устанавливаем начальный индекс макс. эл.

for i in range(n-1): #поиск индекса макс. эл.

   if(a[max_number] < a[i+1]):

       max_number = i+1

       

if(max_number == 0): #если индекс макс. эл = 0

   pre_max_number = 1 #начальный индекс второго макс. эл. = 1

else: pre_max_number = 0 #иначе 0

for j in range(n-1): #поиск индекса второго макс. эл.

   if(j+1 != max_number and a[pre_max_number] < a[j+1]):

       pre_max_number = j+1

       

print(max_number, pre_max_number) #вывод их на экран



Новые вопросы