Информатика, вопрос задал IVAN2349 , 2 года назад

ПИТОН 60бал
Определите среднее арифметическое элементов последовательности, завершающейся числом 0. Число 0 в последовательность не входит. Числа, следующие за нулем, считывать не нужно.
Входные данные
Вводится последовательность целых чисел. Ввод завершается, когда будет введено число 0.
Выходные данные
Выведите одно число - среднее арифметическое элементов последовательности

Ответы на вопрос

Ответил Archistein
1

Ответ:

a = 1

avg = 0

count = 0

while a != 0:

   a = int(input())

   if a != 0:

       count += 1

   avg += a

print(avg/count)

Новые вопросы