Информатика, вопрос задал dyrkahub32 , 2 года назад

Питон
1. Напишите программу, которая вводит символьную строку и определяет, сколько раз в ней встречается буква «Ю». Пример:
Введите строку: АЮАЮАЮЮ
Букв "Ю": 4

2. Напишите программу, которая вводит символьную строку и определяет, сколько раз в ней встречается сочетание букв «АЮ». Пример:
Введите строку: АЮАЮАЮЮА
Количество "АЮ": 3

3. Напишите программу, которая вводит символьную строку, содержащую текст с пробелами, и определяет, сколько в ней слов (словом считается последовательность символов, не содержащая пробелов). Слова могут быть разделены несколькими пробелами. В начале строки пробелов нет. Подсказка: ищите начало слова. Пример:
Введите строку: Однажды в студёную зимнюю пору
Слов: 5

Ответы на вопрос

Ответил bilanovfatim
6

Ответ:

1)

stroka = input()

count = 0

for i in stroka:

 if i == 'Ю':

   count += 1

print(f'Букв "Ю": {count}')

2)

stroka = input()

count = 0

a = list(stroka)

for i in range(0, len(a) - 1):

 if a[i] == 'А' and a[i+1] == 'Ю':

   count += 1

print(f'Количество "АЮ": {count}')

3)

stroka = input()

a = list(stroka)

b = [0]*a.count(' ')

print(f'Слов: {len(b)+1}')

Объяснение:

Новые вопросы