Информатика, вопрос задал nikushakalinina2005 , 2 года назад

Переписать программу в питон
Var a, n:
integer;
begin
n:=0;
repeat
readln(a);
if (a mod 3 = 0) and (a mod 6 <> 0) then
inc(n, a);
until a = 0;
writeln(n);
end.

Ответы на вопрос

Ответил pinguinbird
1

Ответ:

n=0

a=1

while a != 0:

   a = int(input("Введите а:"))

   if a%3 == 0 and a%6 != 0: n+=a

print(n)

Но вообще странная программа... Точно нет ошибок в задании?


nikushakalinina2005: Напишите программу, которая находит количество чисел, кратных 3, но не кратных 6, в последовательности целых чисел. Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа по модулю не превышают 30 000.
Программа должна вывести одно число — сумму чисел, кратных 3 и не кратных 6, встречающихся в последовательности.
nikushakalinina2005: Изначально задание выглядело так. Мне кажется все верно, если нет, то прошу Вас о помощи )
pinguinbird: Не, надо по-другому писать
pinguinbird: сделаю к вечеру
Новые вопросы