Паскаль. Задайте массив из 10 случайных целых чисел из интервала [-5;5] .Определите сколько раз в массиве встречается число 3
Psihocover:
вам надо только 3 положительные? или отрицательные 3 тоже?
Ответы на вопрос
Ответил Psihocover
1
program count3;
const
N=10;
var a: array [1..N] of integer;
i,count : integer;
begin
count:=0;
cls;
writeln ('Массив [-5;5]');
for i:=1 to N do begin
A[i]:=random (11)-5;
write (A[i]:4);
if A[i] = 3 then
count:=count+1;
end;
writeln;
writeln ('Количество троек в массиве : ', count);
end.
const
N=10;
var a: array [1..N] of integer;
i,count : integer;
begin
count:=0;
cls;
writeln ('Массив [-5;5]');
for i:=1 to N do begin
A[i]:=random (11)-5;
write (A[i]:4);
if A[i] = 3 then
count:=count+1;
end;
writeln;
writeln ('Количество троек в массиве : ', count);
end.
иначе 5 никогда не будет в массиве!
Новые вопросы
Қазақ тiлi,
2 года назад
Физика,
7 лет назад