Информатика, вопрос задал Оксана2416 , 2 года назад

paskal выдаёт ошибку, помогите пожалуйста испрвить:
Задача:Написать программу, которая проверяет, является ли четным введенное пользователем целое число.
program cisla;
var
a:integer;
begin
writeln('Введите число, ');
readln(a);
if a mod 2=0 then writeln('Число четное');
else
writeln('Число нечетное');
readln
end.


Аноним: Почему не указали, где именно ошибка и какое сообщение?
nestyme: потому что ошибка тут очевидна, она не логическая, а чисто синтаксическая.
Аноним: Да я вижу, что перед else ;
Аноним: И компилятор её сразу указывает.. Но может у человека еще что-то выдается, мало ли...
nestyme: да нет, тут все верно:)
Оксана2416: нет, всё нормально)спасибо. я просто немного ступила

Ответы на вопрос

Ответил nestyme
1
перед "else" не нужна точка я запятой;)
Новые вопросы