Информатика, вопрос задал NesmeyanaDurinda , 8 лет назад

ПАСКАЛЬ
Вводится последовательность целых чисел до 0. Вычислить последовательность элементов выделенной последовательности (через while или repeat)

Ответы на вопрос

Ответил yasia228
0
// PascalABC.NET 3.2, сборка 1325 от 19.10.2016
begin
  var s:= new stack<integer>;
  var n:integer;
  Writeln('Вводите числа, ноль завершает ввод');
  repeat
    Read(n);
    if n<>0 then s.Push(n);
  until n=0;
  for var i:=1 to s.Count do begin
    Write(s.Peek,' ');
    s.Pop
    end;
  Writeln
end.

кажется так
Ответил NesmeyanaDurinda
0
Я не понимаю, что обозначает s.Push. А еще в этой задаче при repeat можно написать программу без for.
Новые вопросы