Информатика, вопрос задал Soffi7bayard , 7 лет назад

(Паскаль) Составьте программу вывода на экран всех простых чисел, не превосходящих заданного N. Простым называется натуральное число больше единицы, имеющее только два делителя: единицу и само это число. Для проверки подготовить код программы и результаты ее работы.

Ответы на вопрос

Ответил raf1O5
0

Код программы

program raf105;

var i,j,o,n:integer;

begin

write('Введите число N: ');

readln(n);

writeln('Вывод: ');

for i:=2 to n-1 do

begin

 o:=0;

 for j:= 1 to i do

   if (i mod j)=0

     then o:= o+1;

 if o=2

   then writeln(i);

end;

end.

     

Результаты работы программы

Введите число N: 15

Вывод:

2

3

5

7

11

13

Новые вопросы