Информатика, вопрос задал Lakalutik , 9 лет назад

Паскаль. Составьте программу вычисления суммы 150 первых членов арифметической прогрессии, если a1 = –200; d = 0,2.( с помощью repeat)

Ответы на вопрос

Ответил averutin
0
program prg;
const
n = 150;
a1 = -200;
d = 0.2;
var
c : integer;
an : double;

begin
c := 1;
repeat
an := a1 + (c-1) * d;
write(an:5:2, ', ');
inc(c);
until c=n;
writeln;
end.
Новые вопросы