Информатика, вопрос задал swweg , 10 лет назад

паскаль составьте программу определяющую какие из 4 заданных чисел делятся на 5

Ответы на вопрос

Ответил m0nclous
0
Var a,b,c,d:integer;
Begin
  Write('Введите 4числа: '); readln(a,b,c,d);
 if (a mod  5 = 0 ) then writeln(a,' делится на 5 без остатка');
 if (b mod  5 = 0 ) then writeln(b,' делится на 5 без остатка');
 if (c mod  5 = 0 ) then writeln(c,' делится на 5 без остатка');
 if (d mod  5 = 0 ) then writeln(d,' делится на 5 без остатка');
end.
Ответил m0nclous
0
то что нужно?
Ответил Absolute33
0
program x;
uses crt;
var
mas: array[1..4] of integer;
i:integer;
begin
clrscr;
writeln('Введите 4 числа '')  ;
for i:=1 to 4 do
begin
readln(mas[i]);
     end;   
  for i:=1 to 4 do   
  if(mas[i] mod 5=0)
then
begin
     writeln('Числа без остатка  ', mas[i]);
endelse if (mas[i] mod 5<>0) then
 writeln('Числа с остатком  ', mas[i]) ;
     readln;   
 end.
Ответил m0nclous
0
Думаю она не сможет объяснить учителю массивы :)
Новые вопросы