Информатика, вопрос задал NeiJdjsusj , 2 года назад

Паскаль
Составьте программу, которая заполняет одномерный массив двадцатью первыми натуральными числами, кратными 5 или 7. Полученный массив вывести на экран.

Ответы на вопрос

Ответил foursquare
1
uses crt;var counter:integer;
numbers:array [0..19] of integer;
arrayCounter:integer;
begin
counter := 0;
arrayCounter := 0;
repeat
if(counter mod 5 = 0) or (counter mod 7 = 0) then
begin
numbers[arrayCounter] := counter;
Inc(arrayCounter);
end;
Inc(counter);
until arrayCounter = 20;
for var i := 0 to 19 do writeln(numbers[i]);end.
Новые вопросы